Base | Lab | MCSE

2004 06 10

Base | Lab | MCSE | Servers


Disabled DHCP

Neither of these machines needs to be a DHCP server, since from their point of view, there already is one on the network.

In fact, the DHCP service is provided by the VMWare networking subsystem.

I removed the DHCP role from both boxes.

Base | Lab | MCSE | Servers


Oh, what a glorious sight...

Two virtual machines, running simultaneously, all boote dup in under five minutes. Pity they don't fit side by side on the host desktop, but it still is a magnificent sight; I can't help but thinking about the enourmous amount of complex software that has to work together just for these two windows to do what they are doing right now. (i.e. nothing much)

The NIC icons on both of the machines are constantly flashing; I can't wait to have them up and running like this and to slap a network sniffer inbetween them.

Base | Lab | MCSE | Servers


Small tweaks

Individually, the servers will perform less, but together they should be prevented from pushing the host overboard. So I tweaked the settings a little bit:

  • RAM was decreased to 196MB per machine. Why that number? Because I like it, that's why. :)
  • Both servers are now wired to use the same virtual CD-ROM drive. I assume those drives are configured to be read-only anway, so that should not be a problem in itself.
  • I synchronised the configurations: I disabled all the fancier features of VMWare, like snapshotting and drag-n-drop between the host and the guest.
  • Inside both guests, I decreased the desktop resolution to 800x600. Looks like crap, but I need to save on resources.

Base | Lab | MCSE | Servers


Two on one

After days of sslloowwllyy installing servers, I am now in a position to have them running side by side on the host machine. Fingers crossed...

Base | Lab | MCSE | Servers | Server02


OS Installation

With the newly created bootable ISO a a virtual CD-ROM drive, I kicked off the installation of this second server. Sure enough, things went by quicker than the installation of the first one, but that might just as well be because of not using the external hard drive anymore.

I busied myself with reading about hotfixes and slipstreaming and every now and then entering a few details for the installation process.

I used the same options as for Server01, other than (obviously) the server name.

On several occasions, I got the impression that all activity inside the virtual machine had stopped, only to 'wake up' again when I switched the focus back to the window. Also, I switched back on various occasions when the installation was waiting at a prompt. Not in the least, I was also downloading some fairly large files and playing music through iTunes. All in all, I think these were not ideal circumstances for a fast installation. Nevertheless, it took only a little over an hour and a half to complete, including the installation of VMWare tools. (every reboot takes around 10 minutes, so time does go by quickly)

Base | Lab | MCSE | Servers | VMWare


Using an ISO image instead of a CD drive

Whilst I was on the VMWare site looking for the exact command line parameters to use in a custom shortcut for Server01, I came across the marvellous idea to create an ISO file from a CD-ROM and mount that ISO file as a virtual disk in a virtual machine.

That would allow me to do all kinds of install without having to even have the Windwos Server 2003 CD available, or even the drive.

What's more, the transfer of files at installation time is likely to go a lot faster than when reading from an external device.

Base | Lab | MCSE | Servers | Server01


Setting up the paging file

The situation is a bit weird in this case, but I think the basic idea still holds: putting the OS files and the Virtual Memory Paging File (commonly known as a swap file) on the same partition is asking for trouble, if only because of fragmentation.

At the very least, I always try to create a seperate partition to use for swap, if not an actual seperate disk. The maximum wisdom in these matters is to divide your swap requirement over as much bus capacity as possible, but avoiding otherwise busy areas. So: not on the same partition as the OS. If there are two physical disks, then one-third on the disk that also has the OS and the rest on the other disk. Never on two partitions on the same disk; that would just make the head move around like mad and slow things down all around.

In this case, everything actually resides on the same file system on the same disk in the Host OS, so the logic hardly applies. My only reasons for creating a seperate virtual disk and using that is that the fragmentation issue is still relevant and that it is more manageable, in case I decide to expand the disk setup in future.

Like real ones, virtual disks can be swapped in and out of a system or replaced with bigger or smaller ones, but doing the same with partitions requires much more difficult procedures and low-level fiddling with tools like PartitionMagic. All in all, I would just a much avoid having to that altogether.

In the end, I formatted the (very much overcapacitated) swap drive and moved the swap file from the OS drive onto the swap drive.

Base | Lab | MCSE | Servers | Server01


Disks moved to the host's hard drive

As outlined earlier, I have moved the virtual disks to the hard drive of the host machine, my laptop. The assumption was that that would make a difference in performance. Well ... let's just say that my instincts were right: the Virtual machine with Server 2003 installed has been tuned down to 'merely' 384MB of RAM and it still starts up three times faster than it did when its disks were physically on the external drive.

2004 06 09

Base | Lab | MCSE | Servers | Server01


Networking up and running

Soon after trying to do the first thing that involved networking (connecting from the host to the guest using Remote Desktop, to be precise) I found out that networking was not operational.

The first thing that I did was to configure the VMWare networking subsystem. Sort of like a virtual machine provides a machine's hardware, there is a service installed that provides the machine's networking environment. This means a NIC inside the virtual machine, but also one or more NICs on the host. VMWare is able to act as a bridge, connecting the virtual 'internal' network to actual outside NICs, thus providing virtual machines with connectivity to the rest of the world, beyond the host.

I opted for host-only networking (which effectively disables outside access for the virtual machine; the concept is like plugging a cable into a router that is local to this small network.

To avoid confusion between the private IP range on my home network and the private IP range on the host-based network, I set the DHCP range to use the network.

Apparently, newly configured Windows 2003 servers don't even bother looking for a DHCP server, so I changed the TCP/IP properties to 'Obtain an IP address auomatically'. I have often wondered why Microsoft don't just call this option 'Use DHCP when available', which would be a much more accurate description of what it actually does. Oh, well, it works anyway.

With the NIC disabled and re-enabled, Server01 has now got an IP address that is actually on the network it is on and I can ping the box from the host. Strangely enough, I couldn't seem to do that the other way around at first. Then it hit me that I usually have Norton Internet Security running, which is (among other things) a firewall, which undoubtly blocks incoming ICMP messages.

I say undoubtly, because making sure is just too much work to find out. I reckon I won't be using that product for very much longer, especially when XP SP2 comes out with its vastly improved built-in personal firewall. NIS seems to be wanting to do the right thing (configure all applications exactly according to their needs and only allowing incoming traffic when there is a corresponding application running) but the interface is so incredibly clunky that I can't seem to deal with it. Also, it appears to have a very hard time remembering settings. But that is the topic of another rant, another time.

After disabling the firewall and bouncing the host NIC (to get the right IP address from the reconfigured DHCP server) I had connectivity in two directions and I was able to set up a Remote Desktop session.

Base | Lab | MCSE | Servers | Server01


I really have to move the virtual disks

This setup really is too slow to work with and I can not help but think that the external disk is the biggest culprit. So there is nothing left to do but move the virtual disks (2 times 2GB, although on the actual host file system they are much smaller, following usage inside the guest) to the laptop's hard drive.

That does present me with a problem that I had really wanted to avoid having to solve: moving my MP3s off that disk, so that enough space is cleared up. Moving them in itself is not that big a deal: I have them backed up on the external drive as it is anyway and 99.9% of the time that I am playing music it is at home, with the laptop hooked up to a HiFi system anyway.

The only problem is that in my past experience and from what I have read on various fora, iTunes will do anything in its power that it can to treat moved files as new ones, thus losing play count and 'last played' dates. I have an intricate system of 'Smart Playlists' in use that depend on these two data items heavily and it has taken me literally months to get the whole Library sufficiently randomised for it to work--hardly something I want to give up easily. Time for a sub-project...

Base | Lab | MCSE | Servers | Server01


Domain setup

After restarting from the VMWare tools installation, at least the screen looks decent and the mouse pointer is responsive. Other than that, it is a very slow affair. It looks like I will have to shut down most or all of the activity on the host machine, in order to conserve CPU resource. This ought to be fun when I have two or even three of these running. :)

As per instructions, I create the domain name, which automatically sets the NetBIOS name of this box to CONTOSO. I let the install do whatever it feels like next, which seems to include a reboot. See you a bit later, then...

Base | Lab | MCSE | Servers | Server01


Installing VMWare tools

This is so nifty: it used to be that you had to do some tricky stuff with the interface and the OS, which would replace your floppy drive temporarily with a built-in virtual drive. All right, but it did require some manual actions on behalf of the user.

Now, it is just a menu option in the interface. A drive will appear within Windows and it will autorun the setup. I opt for the custom option, so that I can opt out of the SCSI acceleration (don't need it) and the host-guest file sharing option (don't want it, since I will be doing all kinds of network stuff on these boxes and I do not need surplus confusion).

Installing is a snap; a reboot is advised, so I do that.

Base | Lab | MCSE | Servers | Server01


first logon

Sure enough, the box rebooted by itself and I was able to log on. Now for the few initial pieces of setup and I will have sucessfully installed a Windows Server 2003 Enterprise Edition machine. :)

The OS rightly complains about a very low resolution and color setting. It offers to correct it automatically and I take the offer. Neverthelss, I should install VMWare tools first.

Base | Lab | MCSE | Servers | Server01


OS basic configuration

As per instructions, I configure the OS for the right keyboard and time zone. I also leave the network settings to 'not belonging in a domain, but part of workgroup 'WORKGROUP'.

I supply a password for the administrator account. The book says it will accept either very good paswords or total blanks. I tried something inbetween and sure enough, the thing complained about it. It did give me the option to proceed anyway, which might mean that the book is in error. I'll try that another time, for now I have just put in an acceptable password.

The installation continues with copying files and configuring the installation. It seems to take long times without any obvious activity, barring the small squares in the bottom right corner that light up in sequence. The timer claims something like 27 minutes to go, but the underlying algorithm does not seem to be very informed about the relation between time passed and the time needed to actually perform the tasks ahead.

Nevertheless, it is all sailing smoothly ahead.

Base | Lab | MCSE | Servers | Server01


OS: Initial setup

As expected, with the Windows Server 2003 Enterprise Edition CD in the external drive, the Virtual Machine happily boots up and starts the setup procedure from CD.

Unlike I expected, the initial file transfer is taking a very long time. In fact, I have done more than a few installations of Windows 2000 from the four-floppy disk set that you can create, and in my recollection, that went through noticeably faster.

Maybe the problem is bus contention: the disk on which the virtual disks are stored is an external drive on a USB2.0 connection. fast enough for continuous drive oprations, but it eats system resources when multiple processes are accessing files, because unlike with an IDE controller, the OS must do a lot of work to manage the USB traffic.

I can't say for sure without doing the whole thing twice with a stopwatch, but killing eMule (which has dozens of files open on that same drive) seems to speed things up a little bit. Still darn slow, though.

As per the instructions in the book, modified for my situation, I configure the drives and partitions. I am leaving the swap partition unformatted for now; that can be done in Disk Administrator at a later time. Besides, there is no obvious option at this point to format both partitions.

Base | Lab | MCSE | Servers | Server01


Hardware parameters

I want to have a seperate disk to use as a swap drive for my virtual servers. That makes the total set of parameters:

  • 788MB of RAM. I have 1GB in the host machine, so it is available. At the time when I will be running more than one server, it is easily enough decreased. Until that time, more RAM makes the VM a lot faster.
  • The primary hard drive (master on IDE0) is a 2GB drive. The drive intended for swap is also 2GB, on IDE1.
  • Networking is limited to the 'host-only' option, because even though there is hardly anything to damage on my network, I want to limit the networked exposure these servers get. It isn't too difficult to accidentally hook them up with a live Internet connection and these things are not patched at all. Given the time constraints that I am working under, a heavy worm or virus infection is just too much fun to be dealing with.
    I am assuming that the host-only option means that two virtual machines running on the same host will be able to communicate with each other. If not, settings are changed easily enough. (why people bother with real hardware, I don't know... :)

Base | Lab | MCSE | Servers | Server01


Starting installation

WIth everything I need downloaded, it is time to start the installation. A tad later than I had hoped (I had hoped for 10:00 am this morning :) but the night is still young and this process is going to take a fairly long time of waiting. It should blend in with the rest of my evening just fine.

Base | Lab | MCSE | Servers | VMWare


No, wait, hang on

Rather than wait for a web master to get back to me, I figured I might as well have a browser window babysit the site that I am interested in. So I called up the page again and whilst it was still loading (or not, rather) I set an autoreload on the tab.

Contrary to my expectations, the page loaded, although it surely took its time. I proceeded to download the binary, cancel the download in eMule and sent a message to the web master to never mind about full outage.

Base | Lab | MCSE | Servers | VMWare


Alternative means

Normally, I shy away from this kind of thing, but given the circumstances I will forgive myself.

Seeing as I can't seem to reach the download section of the VMWare site, I have looked for a copy of the binaries on the eDonkey network. As luck would have it, it also had me stumble onto a key generator. That will save me from having to register for an eval key with no intention of buying the product. Actually, it saves VMWare more time than me. I promise (as I have done before---and made good upon) to buy a licensed copy as soon as either I can afford it or I can get an employer to fork out for it.

Base | Lab | MCSE | Servers | VMWare


Getting a copy of the binary

Simple enough: head over to and find the binary download section.

No such luck: for some reason, I could not get to the actual page to download a binary copy. In fact, it seems like everythign that has anything to do with the 'vmwarestore' just is not responding. It is not completely dead either: FireFox would have times out much earlier if there would have been an actual network problem. It seems like the web server is just keeping the client hanging on.

I confirmed my findings in several ways and killed off other programs that might be choking the network on my end (such as eMule, which has a habit of exhausting network sockets). Other web sites seem to be fine, though. As is, in fact, most of the VMWare site itself. I have sent an email to the web master to alert them of this problem.

Base | Lab | MCSE | Servers | VMWare



The initial idea I had was that I would blow the dust off the Linux box in the server cabinet in the attic and create myself some Virtual Machines for this purpose; I still have a copy of VMWare (properly licensed and all) on that machine, from way back when.

There were some problems with that plan, though:

  • Although it has 748-something MB of RAM, the CPU is a lowly 800MHz P3. (at best, it might even be a lesser spec).
  • The copy of VMWare is of the 1.x or 2.x variety; not likely to support Windows Server 2003.
  • The disks in that machine do not have a great deal of space available, because I have been dumping all kinds of stuff on there for ages. Nothing that could not be cleaned out or archived to CDs or something, but that would still be several days' worth of sifting through files.

Then it hit me: my primary workstation is a laptop with a 1.6MHz Centrino and a whopping 1GB of RAM. Also, I have a 250GB external harddrive attached. Disk performance over USB2.0 will not be fantastic (maybe I shouls switch it to FireWire to see if that makes a big difference) but with that amount of RAM, it is likely to be allright. Better, in any case, than anything I could possibly do on that Linux box.

What's more: I can download an eval copy of VMWare 4.5.1 and be assured of the latest and greatest in features and support.

2004 06 06

Base | Lab | MCSE | Servers


Knowledge first, practice later

Thinking about the trade-off between spending lots of time now on getting a hardware platform up and running and continue working through the books, leaving the hands-on exercises until later, I am leaning heavily towards the latter option.

I will start building the environment on Wednesday afternoon, a time when studying quietly is not an option anyway on account of the cleaning lady and the vacuumer.

Base | Lab | MCSE | Servers



The only thing that is really obvious is that I do not have two or more spare machines lying around that can reasonably be considered powerful enough to run Windows Server 2003.

Next consideration is the Linux machine, Denver. I have used it for VMWare before and at some time in the distant past, I have upgraded the RAM to something like 748MB. As I recall, Windows 2000 workstation ran decent enough, once the disk cache was filled. Not quite the same as what I have in mind now, but really, a working system is more important than high-spec performance.

The only problem will be that even a minimal setup will require something like 2GB hard drive space; probably more if I configure a large swap partition as well. The machine has two hard drives, but I don't think that there will be enough space on it. That would mean I would have to either archive as much as I can off that box and onto CDs or do the same with less accuracy and thrash it for a completely new install (long overdue anyway). Looks like a day or two work in any case, which is not ideal by far.

Base | Lab | MCSE



For various reasons I won't go into now, I have decided to take the MCSE exams. Initially, that just means gathering the knowledge one would need to pass those exams. I started out in the obvious place, by buying and working through the Windows Server 2003 Core Requirements Study Kit.

This project starts off with the necessary setup that I will have to do be able to do the exercises in the books. Other than that, it will give me ample opportunity to play around with throw-away Windos Server 2003 machines; an opportunity I normally do not get very often.